Status update March 27, 2020
Incident Report for Fronter
Resolved
All systems operational
Posted Mar 30, 2020 - 08:55 CEST
Monitoring
All systems operational - Due to the number of schools transitioning to remote learning all over the world, we are experiencing exceptionally high traffic. Read more about the measures we are implementing on our blog:
https://itslearning.com/global/news/continued-efforts/
Posted Mar 26, 2020 - 10:25 CET