Slowness on Assignment tool
Incident Report for Fronter
Resolved
The issue has been resolved.
Posted Mar 02, 2020 - 09:48 CET
Monitoring
We were experiencing some slowness on Assignment tool earlier this morning. Some users may not have been able to open Assignments. We have implemented a fix and are currently monitoring.
Posted Mar 02, 2020 - 09:33 CET