Performance issues
Incident Report for Fronter
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 11:08 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2020 - 10:59 CEST
Investigating
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load.

Our engineers are investigating the problem and will resolve it soon.
Posted Aug 24, 2020 - 10:45 CEST