Performance issues
Incident Report for Fronter
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 16:58 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2020 - 15:32 CEST
Investigating
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load.

Our engineers are working to identify the root cause and implement a solution.
Posted Aug 24, 2020 - 15:04 CEST