Connection issues for some customers
Incident Report for Fronter
Resolved
The issue is now resolved for the affected customers.
Posted May 28, 2018 - 16:33 CEST
Investigating
Some of our customers may experience an issue when trying to connect to Fronter. We are working on this issue.
Posted May 28, 2018 - 15:46 CEST